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7 Interacting with Users

Apple Remote Desktop is a powerful tool for interacting with 
computer users across a network. You can interact by 
controlling or observing remote screens, text messaging with 
remote users, or sharing your screen with others.

This chapter describes Remote Desktop’s user interaction capabilities and gives 
complete instructions for using them. You can learn about:
Â “Controlling” on page 78
Â “Observing” on page 85
Â “Sending Messages” on page 92
Â “Sharing Screens” on page 93
Â “Interacting with Your Apple Remote Desktop Administrator” on page 94
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Controlling
Apple Remote Desktop allows you to control remote computers as if you were sitting in 
front of them. You can only control the keyboard and mouse of any one computer at a 
time. There are two kinds of remote computers that Apple Remote Desktop can 
control:  Apple Remote Desktop clients and Virtual Network Computing (VNC) servers.

Controlling Apple Remote Desktop Clients
Apple Remote Desktop client computers can be controlled by any administrator 
computer that has the Control permission set. See “Apple Remote Desktop 
Administrator Access” on page 59 for more information about Apple Remote Desktop 
permissions.

While you control an Apple Remote Desktop client computer, some keyboard shortcut 
commands are not sent to the remote computer, but they affect the administrator 
computer. These include:
Â Change Active Application (Command-Tab and Command-Shift-Tab)
Â Show or Hide Dock (Command-Option-D)
Â Log Out User (Command-Shift-Q)
Â Take Screen Shot (Command-Shift-3, -4)
Â Force Quit (Command-Option-Escape)
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Also, special keys including the sound volume, screen brightness, and Media Eject keys 
do not affect the client computer.

These instructions assume the that observed computer has Apple Remote Desktop 
installed and configured properly (see “Setting Up an Apple Remote Desktop Client 
Computer for the First Time” on page 41) and that the computer has been added to an 
Apple Remote Desktop computer list (see “Finding and Adding Clients to Apple 
Remote Desktop Computer Lists” on page 49).

To control an Apple Remote Desktop client:
1 Select a computer list in the Remote Desktop window.

2 Select one computer from the list.

3 Choose Interact > Control.

4 To customize the control window and session, see “Control Window Options” on 
page 79.

5 Use your mouse and keyboard to perform actions on the controlled computer.

If your Remote Desktop preferences are set to share keyboard and mouse control, the 
remote computer’s keyboard and mouse are active and affect the computer just as the 
administrator computer’s keyboard and mouse do.

If your preferences aren’t set to share control, the remote computer’s keyboard and 
mouse do not function while the administrator computer is in control.

Control Window Options
When controlling a client, the control window contains several buttons in the window 
title bar which you can use to customize your remote control experience. There are 
toggle buttons that switch your control session between two different states, and there 
are action buttons that perform a single task. In addition to the buttons, there is a 
slider for image quality.

The toggle buttons are:
Â Control mode or Observe mode
Â Share mouse control with user
Â Fit screen in window
Â Lock computer screen while you control
Â Fit screen to full display

The action buttons are:
Â Capture screen to a file
Â Get the remote clipboard contents
Â Send clipboard contents to the remote clipboard
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Switching the Control Window Between Full Size And Fit-To-Window
When controlling a client, you can see the client window at full size, or scaled to fit the 
control window. Viewing the client window at full size will show the client screen at its 
real pixel resolution. If the controlled computer’s screen is larger than your control 
window, the screen show scroll bars at the edge of the window.

To switch in-a-window control between full size and fit-to-window modes:
1 Control a client computer.

2 Click the Fit Screen In Window button in the control window toolbar.

Switching Between Control and Observe Modes
Each control session can be switched to a single-client observe session, in which the 
controlled computer no longer takes mouse and keyboard input from the 
administrator computer. This allows you to easily give control over to a user at the 
client computer keyboard, or place the screen under observation without accidentally 
affecting the client computer.

See “Observing a Single Computer” on page 90 for more information on Apple Remote 
Desktop observe mode.

To switch between control and observe modes:
1 Control a client computer.

2 Click the Control/Observe toggle button in the control window toolbar.

Sharing Control with a User
You can either take complete mouse and keyboard control or share control with an 
Apple Remote Desktop client user. This allows you to have more control over the client 
interaction as well as prevents possible client side interference.

This button has no effect while controlling VNC servers. See “Controlling VNC Servers” 
on page 82 for more information.

To switch between complete control and shared mouse modes:
1 Control a client computer.

2 Click the “Share mouse and keyboard control” button in the control window toolbar.
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Hiding a User’s Screen While Controlling
Sometimes you may want to control a client computer with a user at the client 
computer, but you don’t want the user to see what you’re doing. In such a case, you 
can disable the client computer’s screen while preserving your own view of the client 
computer. This is a special control mode referred to as “curtain mode.” You can change 
what’s “behind the curtain” and reveal it when the mode is toggled back to the 
standard control mode.

To switch between standard control and curtain modes:
1 Control a client computer.

2 Click the “Lock computer screen while you control” button in the control window 
toolbar.

Capturing the Control Window to a File
You can take a picture of the remote screen, and save it to a file. The file is saved to the 
administrator computer, and is the same resolution and color depth as the controlled 
screen in the window.

To screen capture a controlled client’s screen:
1 Control a client computer.

2 Click the “Capture screen to a file” button in the control window toolbar.

3 Name the new file.

4 Click Save.

Switching Control Session Between Full Screen and In a Window
You can control a computer either in a window, or using the entire administrator 
computer screen. The “Fit screen to full display” toggle button changes between these 
two modes.

In full screen mode, the client computer screen is scaled up to completely fill the 
administrator screen. In addition to the client screen, there are a number of Apple 
Remote Desktop controls still visible overlaying the client screen.

In in-a-window mode, you can switch between fitting the client screen in the window 
or showing it actual size, possibly scrolling around the window to see the entire client 
screen. See “Switching the Control Window Between Full Size And Fit-To-Window” on 
page 80 for more information.

To switch between full screen and in-a-window modes:
1 Control a client computer.

2 Click the “Fit screen to full display” button in the control window toolbar.
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Sharing Clipboards for Copy and Paste
You can transfer data between the Clipboards of the administrator and client computer. 
For example, you may want to copy some text from a file on the administrator 
computer and paste it into a document open on the client computer. Similarly, you 
could copy a link from the client computer’s web browser and paste it into the web 
browser on the administrator computer.

The keyboard shortcuts for Copy, Cut, and Paste are always passed through to the 
client computer.

To share clipboard content with the client:
1 Control a client computer.

2 Click the “Get the remote clipboard contents” button in the control window toolbar to 
get the client’s Clipboard content.

3 Click the “Send clipboard contents to the remote clipboard” button in the control 
window toolbar to send content to the client’s Clipboard.

Controlling VNC Servers
Virtual Network Computing (VNC) is remote control software. It allows a user at one 
computer (using a “viewer”) to view the desktop and control the keyboard and mouse 
of another computer (using a VNC “server”) connected over the network. For the 
purposes of these instructions, VNC-enabled computers are referred to as “VNC clients.”

VNC servers and viewers are available for a variety of computing platforms. Remote 
Desktop is a VNC viewer and can therefore control any computer on the network 
(whether that computer is running Mac OS X, Linux, or Windows) that is:
Â Running the VNC server software
Â In an Apple Remote Desktop computer list

If the you are trying to control a VNC server which is not Remote Desktop, it will not 
support Remote Desktop keystroke encryption. If you try to control that VNC server, 
you will get a warning that the keystrokes aren’t encrypted which you will have to 
acknowledge before you can control the VNC server. If you chose to encrypt all 
network data, then you will not be able to control the VNC server because Remote 
Desktop is not able to open the necessary SSH tunnel to the VNC server. For more 
information, see “Encrypting Observe and Control Network Data” on page 75.

These instructions assume the observed computer has been added to an Apple 
Remote Desktop computer list (see “Finding and Adding Clients to Apple Remote 
Desktop Computer Lists” on page 49). When adding a VNC server to an Apple Remote 
Desktop computer list, you only need to provide the VNC password, with no user name.

To control a VNC client computer:
1 Select a computer list in the Remote Desktop window.
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2 Select one computer from the list.

3 Choose Interact > Control.

If the controlled computer’s screen is larger than your control window, the screen 
scrolls as the pointer approaches the edge of the window.

4 To customize the control window and session, see “Control Window Options” on 
page 79.

5 Use your mouse and keyboard to perform actions on the controlled computer.

Regardless of your Apple Remote Desktop preferences, controlled VNC servers share 
keyboard and mouse control. The remote computer’s keyboard and mouse are active 
and affect the computer just as the administrator computer’s keyboard and mouse do.

Setting up a Non–Mac OS X VNC Server
This section contains very basic, high-level steps for setting up a non–Mac OS X client 
to be viewed with Remote Desktop. This section cannot give detailed instructions, since 
the client operating system, VNC software, and firewall will be different.

The basic steps are:
1 Install VNC Server software on the client computer (for example, a PC, or a Linux 

computer).

2 Assign a VNC password on the client computer.

3 Make sure the client’s firewall has the VNC port open (TCP 5900).

4 Make sure “Encrypt all network data” is not selected in the Security section of the 
Remote Desktop Preferences.

5 Add the computer to the Remote Desktop’s All Computers list using the client’s IP 
address.

6 Put the client computer’s VNC password in the Remote Desktop authentication box.

There is no user name for a VNC server, just a password.

Apple Remote Desktop Control and the PC’s Ctrl-Alt-Del
If you use Remote Desktop to administer a PC that’s running VNC, you may be 
wondering how to send the Ctrl-Alt-Del command (Control-Alternate-Delete) from a 
Mac to the PC. Though Mac and PC key mappings differ, you can use an alternate key 
combination to send the command.
Â For full-size (desktop) keyboards, use Control-Option-Forward Delete.
Â For abbreviated keyboards (on portable computers), use Function-Control-Option-

Command-Delete.
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VNC Control Options
After you have added a VNC server to a computer list (or when you are first adding it), 
you can set a custom port for VNC communication, and you can designate a display to 
control.

To set a custom port on an existing computer list member:
1 Select a computer list in the Remote Desktop window.

2 Select a VNC Server computer in the Remote Desktop window.

3 Choose File > Get Info.

4 Click Edit in the Info window.

5 At the end of the IP Address or fully qualified domain name, add a colon followed by 
the desired port.

For example, if you want to connect to a VNC server (vncserver.example.com) that is 
listening on TCP port 15900, you would enter:
vncserver.example.com:15900

6 Click Done.

To set a custom VNC port when adding a computer by address:
1 Choose File > Add By Address.

2 Enter the IP address or fully qualified domain name.

3 At the end of the IP Address or fully qualified domain name, add a colon followed by 
the desired port.

For example, if you want to connect to a VNC server (vncserver.example.com) that is 
listening on TCP port 15900, you would enter:
vncserver.example.com:15900

4 Enter the user name and password.

5 Click Add.

To designate a display to control:
1 Add a custom port number, as described above.

2 Use the display number for the last number in the custom port designation (display 
designations start at 0 for the default primary display).

For example, f you want to control the default display on a VNC server 
(vncserver.example.com) that is listening on TCP port 5900, you would enter:
vncserver.example.com:5900

If you want to control the second display, you would enter:
vncserver.example.com:5901
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If you want to control the third display, you would enter:
vncserver.example.com:5902

Configuring an Apple Remote Desktop Client to be Controlled by a 
VNC Viewer
When configured to do so, an Apple Remote Desktop client can be controlled with a 
non–Apple VNC viewer.

Allowing a non–Apple VNC viewer access to an Apple Remote Desktop client is less 
secure than using Remote Desktop to control the client. The non–Apple VNC software 
expects the password to be stored in a cryptographically unsecured form and location.

To configure a client to accept VNC connections:
1 On the client computer, open System Preferences.

2 Click Sharing, select Apple Remote Desktop, then click Access Privileges.

3 Select “VNC viewers may control screen with the password.”

4 Enter a VNC password.

5 Click OK.

Observing
You may not want to control a computer, but merely monitor what is on its screen. 
Observing a remote computer is similar to controlling one, except your mouse 
movements and keyboard input are not sent to the remote computer. Apple Remote 
Desktop client computers can be observed on any administrator computer that has the 
“Observe” permission set. See “Apple Remote Desktop Administrator Access” on 
page 59 for more information about Apple Remote Desktop permissions.

Warning:  Do not use the same password as any user or Apple Remote Desktop 
administrator. The password may not be secure.
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Remote Desktop allows you to observe multiple clients on the same screen, cycling 
through the list of observed computers. This allows you to monitor many screens 
without having to select each one individually.

Dealing With Many Client Screens
When observing a single client, you can see the client window at full size, or scaled it to 
fit the observe window. To switch between the full size and fitting to the window, click 
the Fit to Window button, just as you would in a control window.

If you’re observing more clients than you’ve chosen to fit on one screen, you can cycle 
through multiple pages by clicking the Previous or Next button.

Cycle Pages:  Use these buttons to manually switch to the previous or next page of 
screens.

Getting More Information on Observed Clients
There is a computer information area beneath each of the observed desktops. It’s 
automatically disabled when the administrator is viewing more computers than the 
computer information area is able to show effectively (a threshhold of about 220 pixels 
across). This could happen if: 
Â the initial selection of computers is too great for the window size
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Â the observe window is resized, shrinking the information beneath the threshold
Â the setting for the number of viewed machines is changed

The computer information area is reenabled when the sizes are returned to more than 
the image size threshhold.

Changing Observe Settings While Observing
While you are observing multiple computers, you can adjust the Apple Remote 
Desktop observe settings using the controls at the top of the observe window.

These settings will be visible after clicking View Options in the toolbar.

To change your observe settings:
Â Page Delay:  Adjust the number of seconds before automatically advancing to the 

next page of screens.

Â Computers per page:  Adjust the number of client screens visible on each page.

Â Image Quality:  Adjust the screen color depth from black and white to millions of 
colors.

Â Titles:  Change the titles of the displayed screens in the computer information area.

Â Account Picture:  Add the currently logged-in user’s account picture under each 
observed desktop.
See “Viewing a User’s Account Picture While Observing” on page 88 for more 
information.

Â Computer Status:  Add a status overview icon underneath the observed desktop.
See “Viewing a Computer’s System Status While at the Observe Window” on page 88 
for more information.
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Changing Screen Titles While Observing
While you are observing multiple computers, you can change the title underneath the 
desktops shown in the observe window.

The main title can be the:
Â Name (the computer sharing name)
Â IP Address
Â Host Name

To change your observe window titles:
1 Click View Options in the observe window’s toolbar.

2 Select Display Computer Information.

3 From the Title pop-up menu, select the desired title.

4 Click Done.

Viewing a User’s Account Picture While Observing
Remote Desktop can display the user’s account picture and a user-created status 
underneath the observed desktop.

The user’s account picture is their system login icon, so it might be either a picture 
taken from an iSight camera, or a custom image selected in the Accounts pane of 
System Preferences.

To view a user’s account picture:
1 Click View Options in the observe window’s toolbar.

2 Select Display Computer Information.

3 Select Account Picture.

4 Click Done.

Viewing a Computer’s System Status While at the Observe Window
Remote Desktop can display certain system status information underneath the 
observed desktop. This information gives you a basic assessment of the following 
service statistics:
Â CPU Usage
Â Disk Usage
Â Free Memory
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There are two levels of detail for system statistics. The top level is a single icon (a red, 
yellow, or green icon).

You show the second level of detail by placing the mouse pointer over the high-level 
status icon. The icon changes to an “i” and you can click the “i” to get more information. 
Clicking the icon exposes per-service status icons: 

Icon Indicates

 or One or more service statistic is red. This takes precedence over any 
yellow or green indicator.

 or One or more service statistic is yellow This takes precedence over 
any green indicator.

Service is operating within established parameters.

No service informaiton available.

Service Icon Status

CPU Usage Usage is at 60% or less

Usage is between 60% to 85%

Usage is at 85% or higher

No status information is available

DIsk Usage Usage is at 90% or less

Usage is between 90% and 95%

Usage is at 95% or higher

No status information is available

Free Memory Less than 80% used

Between 80% and 95% used
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To show system status in the observe window:
1 Click View Options in the observe window’s toolbar.

2 Select Display Computer Information.

3 Select Computer Status.

4 Click Done.

Shortcuts in the Multiple Screen Observe Window
You can access several Apple Remote Desktop commands using icons in the observe 
window. You can customize the observe window with the commands that are most 
useful to you. For example, you may want to access the Copy Items command, the Text 
Chat command, and the Lock Screen command, using the buttons in the observe 
window toolbar. You perform Remote Desktop tasks on any computer by selecting its 
screen and choosing a task from the Remote Desktop menus or the observe window 
toolbar.

Regardless of your toolbar customizations, you’ll be able to advance through pages 
manually, change the titling of the observed screens, change the number of client 
screens per page, change the number of seconds before paging, or change the color 
depth of the observed screens.

Observing a Single Computer
When you observe a single computer, the observed screen appears in a window on 
your administrator computer. If a screen saver is active when you observe the screen, 
the screen saver remains in effect. The observe window contains a “Share mouse 
control” button to switch to controlling the screen.

To observe a single computer:
1 Select a computer list in the Remote Desktop window.

2 Select a computer in the Remote Desktop window.

3 Choose Interact > Observe.

If the observed computer’s screen is larger than the observe window, the screen will 
scroll as the pointer approaches the edge of the window.

4 To customize the single-client observe window and session, see “Control Window 
Options” on page 79. The observe window’s options are the same as those of the 
control window.

Over 95% used

No status information available

Service Icon Status
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Observing Multiple Computers
When you observe multiple client computers, each client screen is scaled down, so that 
several computers can be viewed at the same time. You can set the number of client 
screens that appear at any one time. See “Setting Preferences for the Remote Desktop 
Administrator Application” on page 36 for more information.

If a client has a screen saver running when you start observing, the screen saver 
remains in effect.

The screens will cycle through the entire list of selected computers, a few at a time, 
switching every 30 seconds, altered by the speed setting.

To observe multiple computers:
1 Select a computer list in the Remote Desktop window.

2 Select one or more computers in the selected computer list.

3 Choose Interact > Observe.

The remote computer screens appear in a window.

Observing a Computer in Dashboard
If you are using Mac OS X version 10.4 or later, you can use the Dashboard widget to 
observe one client computer. The computer must be in your All Computers list and be 
authenticated with permission to Observe. Apple Remote Desktop does not have to be 
launched to use the widget.

To observe using Dashboard:
1 Add the computer to your All Computers list.

See “Finding and Adding Clients to Apple Remote Desktop Computer Lists” on page 49 
for detailed information.

2 Activate Dashboard, and click the widget’s icon to run it.

3 Click the widget’s “Info” button to flip the widget over.

4 Supply a hostname or IP address, login name, and password or simply select the 
computer you want to observe (if it’s listed).

5 Click Done.
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Sending Messages
Apple Remote Desktop allows you to communicate with users of Apple Remote 
Desktop client computers using text messaging. You can use text messages to give 
instructions or announcements, to collaborate remotely, or troubleshoot with users. 
There are two types of text messaging:  one-way messages and two-way interactive 
chat. Text messages and chat are available only to Apple Remote Desktop client 
computers; they are not available to VNC client computers.

Sending One-Way Messages
You can use a one-way text message to send announcements or information to users 
client computers. The announcements appear in front of open application windows 
and can be dismissed by the user.

To send a one-way text message:
1 Select a computer list in the Remote Desktop window.

2 Select one computer from the list.

3 Choose Interact > Send Message.

4 Enter your message.

5 Click Send.

The text message appears on the screen of all the selected computers.

Interactive Chat
You can start an interactive text chat with the user of an Apple Remote Desktop client 
computer. This allows instant feedback from users, so you can collaborate or 
troubleshoot.

To begin an interactive chat:
1 Select a computer list in the Remote Desktop window.

2 Select one or more computers in the selected computer list.

3 Choose Interact > Chat.

4 Enter your message, one line at a time.

The message appears real-time on the user’s screen as you type.
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5 Press the Return key to complete and send each line.

Viewing Attention Requests
After a client user sends an attention request, the Apple Remote Desktop administrator 
can read the attention request text.

To view attention requests:
1 Choose Window > Messages From Users.

2 Select the message you want to view.

3 Click Display to view the request’s message.

Sharing Screens
Apple Remote Desktop allows you to show your screen (or the screen of a client 
computer in your list) to any or all Apple Remote Desktop client computers in the same 
computer list. You can, for example, show a presentation to a classroom of computers 
from a single computer.

Sharing a Screen with Client Computers
You can share a client computer’s screen, or the administrator’s screen, with any 
number of clients. The client screen displays what is on the shared screen, but cannot 
control it in any way.

To share a computer’s screen:
1 Select a computer list in the Remote Desktop window.

2 Select on or more computers in the selected computer list.

These computers include the target computers and the source computer.

3 Choose Interact > Share Screen.

4 Select the screen to be shared.

If you want to share the Apple Remote Desktop administrator screen, select “Share your 
screen.” 

If you want to share a client screen, select “Share a different screen,” and drag a 
computer from an Apple Remote Desktop computer list to the dialog.

5 Click Share Screen.

The selected computer shows the shared computer screen.

If the target computer’s screen resolution is lower than the shared computer’s, only the 
top left part of the shared screen (up to the lowest screen resolution) is seen on the 
target screen.
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Monitoring a Screen Sharing Tasks
You may want to keep track of the screen sharing tasks you have begun. You can get 
information on all active screen sharing tasks, and can sort the tasks by time started, 
source screen, or target computers.

To view current active screen sharing tasks:
m Choose Window > Active Share Screen Tasks.

Interacting with Your Apple Remote Desktop Administrator
Users of Apple Remote Desktop client computers can initiate contact with a Remote 
Desktop administrator. Clients can ask for attention from the administrator, or cancel 
that attention request.

Additionally, users of Apple Remote Desktop client computers can set an identifying 
icon for a Remote Desktop administrator to view. The Remote Desktop administrator 
can choose whether to view the icon or not.

Requesting Administrator Attention
At times, Apple Remote Desktop client computer users need to get the attention of the 
Apple Remote Desktop administrator. If an Apple Remote Desktop administrator is 
currently monitoring the client computer, the client user can send an attention request.

To request administrator attention:
1 Click the Apple Remote Desktop status icon and choose Message to Administrator.

The attention request window appears.

2 If the network has more than one Apple Remote Desktop administrator available, 
choose an administrator from the “Send message to” pop-up menu.

3 Enter the message.

4 Click Send.

The attention request icon appears on the administrator’s screen.
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Canceling an Attention Request
If a user no longer needs the Apple Remote Desktop administrator’s attention, he or 
she can cancel the attention request after it has been sent.

To cancel an attention request:
1 Click the Apple Remote Desktop status icon and choose Message to Administrator.

2 Click the Apple Remote Desktop status icon in the menu bar and choose Cancel 
Message.

Changing Your Observed Client Icon
By default, the icon that the Remote Desktop administrator sees while observing is the 
login icon for the currently logged-in user. If you had an iSight camera active when 
setting up your computer, you may have taken a picture of yourself for your user icon.

You can change this icon, and it will change on the administrator’s observation screen.

To change your login icon:
1 Prepare the picture you want to use.

You could use a graphic file, or take a picture using an iSight camera.

2 Open System Preferences.

The System Preferences application launches.

3 Select the Accounts pane.

4 Select your account, and choose the Picture button.

5 Replace your current account picture with the new picture.

6 Close System Preferences.




